Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

4.2 Woes, please, please help.

Discussion in 'General Discussion' started by RCWatchman, Dec 12, 2013.

  1. RCWatchman

    Joined:
    Dec 10, 2013
    Messages:
    18
    Likes Received:
    0
    I did the 4.2 upgrade and took it for a flight. It was OK but danced around a little more than usual. I then found out I needed to incorporate the default settings from the DJI site. I did but all I could find was a ZIP file for the 4.0 default right in with the 4.2 stuff so I used it.
    I installed it and now I get an error 27message and if you look at the compass Mod #s, in the Tools tab you will see the compass is way out of the normal calibration count of 1400 or 1500. It now shows 375.7. The compass was OK until I did the default install. Please help, what should I do.
    I know I could try to readjust the compass with a magnet but this did not go so far out until the firmware change. Has anybody seen this and what did you do to fix. Please respond, please.
     
  2. kenskid

    Joined:
    Aug 3, 2013
    Messages:
    146
    Likes Received:
    1
    I did upgrade yesterday. Did you download the file to reset all parameters also?
     
  3. DiscoDrew

    Joined:
    Dec 3, 2013
    Messages:
    94
    Likes Received:
    1
    Location:
    Teton Valley ID, USA
    It's looks like you did install the parameters as you said. I do not know what version of phantom you have but it's possible when you reset to DJI factory parameters that it switched your controller configuration in naza assistant which breaks the gps link on naza. Try switching controller to D-Bus and save settings. Power cycle phantom and do the compass dance. That may take care of it.
     
  4. RCWatchman

    Joined:
    Dec 10, 2013
    Messages:
    18
    Likes Received:
    0
    I used a magnet on the compass like described in the DJI tutorial. I was able to get it up to 710.0 for the Mod#. The error 27 went away and I was able to complete an advanced calibration.

    But I am still not happy with 710, when it should be 1400 or so. It is cold and late so I will do the dance tomorrow and see where it leaves me.

    I still do not understand why it changed so with the new firmware.

    DiscoDrew, How do I change to D bus?

    Regardless, thank you all, and if you can think of anything else, please let me know. I will report back tomorrow, very late here.
     
  5. netphreak

    Joined:
    Sep 17, 2013
    Messages:
    228
    Likes Received:
    0
    You do NOT need a magnet for these low compass values! The error 27 means you need to do a compass calibration before your next flight. Dji is doing this on purpose with those parameters.
     
  6. DiscoDrew

    Joined:
    Dec 3, 2013
    Messages:
    94
    Likes Received:
    1
    Location:
    Teton Valley ID, USA
    I am not sure if you will need to switch to D-Bus (depends on your Phantom Ver.). Also, if everything is working and you got a successful calibration then I am thinking thats the not the cause of your lower values.

    To answer your question though, you can check your control setting in Naza Assistant under the RC Tab. Can't hurt to try, can easily be set back to PPM.

    Netphreak is right too, the Error 27 can simply mean it needs a recalibration due to the parameter reset. However, I think for some (depending on Phantom ver.) the D-Bus selection needs to take place before the said compass calibration.

    Let us know how it goes, makes it easier for the next guy searching similar issues. Good luck!
     
  7. RCWatchman

    Joined:
    Dec 10, 2013
    Messages:
    18
    Likes Received:
    0
    OK, let me tell you what I’ve got. I had to use a magnet on the compass because the compass Mod # at 300 or so would not let me calibrate the IMU with the computer. I got the mod # to 720, calibrated, reset defaults, took it out to fly, did the dance, it found the satellites did the multi green blink recording home. I started the motors let it sit for 30 seconds and took off. I brought it to a 5 foot hover. While in the hover it started to go into a circle fly around about an 8 foot circle with no input from the TX. I can fly it but when I go hands free it goes into the circle flight again. But always facing one direction.

    Now after about 5 minutes it seemed to be a little more stable but twitchy with no input from the radio. It would drift some but not that circle.

    Any suggestions? I really don’t want to backwards in firmware, but I am asking for any input you would be willing to give. Right now it is all stock and only has about 20 flights.

    Please let me know what you think, and again I thank all of you.
     
  8. Thor 555

    Joined:
    Dec 13, 2013
    Messages:
    12
    Likes Received:
    0
    Location:
    Istanbul, Turkey
    Just had the same problem half an hour ago with the 4.02 update and had abnormally low compass MOD numbers. But you may have made matters worse by using the magnet.

    I went to the DJI web site, clicked on Phantom and then Downloads. At the bottom of the Phantom downloads you'll see a zip file "Phantom Default Configuration Parameters" Download it and unzip it to a place on your computer where you can find it later.

    Then open the Naza Assistant program. Connect your Phantom to your computer, turn on your transmitter, connect your LiPo. In the Tools Menu click on "Import Parameters". Find the unzipped Phantom parameters file and click on it to download it to your Phantom.

    If your transmitter came installed with the tilt lever on the back side for the Zenmuse gimbal, in the Naza program go to the Basic Menu and select the D-Bus option. Otherwise, select the PPM option. Newer models use the upgraded D-Bus option while the older ones use PPM.

    Then do the IMU calibration in the Tools Menu after which you'll get an ERROR 27 message.

    Disconnect the LiPo and disconnect the Phantom from the computer. Then with the transmitter turned on, reconnect the Lipo and power up the Phantom normally as you would for a flight. After a short while you'll get an alternate red/yellow flashing light on the Phantom's LED.

    At this point do the compass dance to calibrate the compass and disconnect it.

    Then reconnect the Phantom to the Naza Assistant program on your computer and do the IMU calibration again. The compass MOD should return to a more normal range.

    I did this in my apartment which is full of electro-magnetic interference but will do the compass dance again out in the field before my first flight.

    If the compass MOD figure is still out of line, you might have to undo what you did with your initial magnet swipes on the sensor.

    See if this solves the problem.
     
  9. MILLER4PRESIDENT2020

    Joined:
    Sep 27, 2013
    Messages:
    304
    Likes Received:
    17
    a little off topic but what is the fix for 4.02? I am on 4.0 and running smoothly but if I have to go through all this trouble I might just stick with 4.0. If there is anything to supposedly help against flyaways then I'll gladly due the upgrade
     
  10. RCWatchman

    Joined:
    Dec 10, 2013
    Messages:
    18
    Likes Received:
    0
    I am so sorry to bother again, but I have a few more questions, please. When you reset the default settings I am using the default download titled 4.00. Is that the right one? And when you click to actually do the reset function it asks if you are sure and tells you to remove the props. Now, the big question, I choose YES and that warning box just disappears, I do not see any progression meter on the computer or anything. Can you tell me if the function has taken place or am I missing something? Please let me know if this is how it works or do you think something is wrong. Pease let me know what you know. Once again I Thank you all that have cared to help you.
     
  11. bees

    Joined:
    Dec 4, 2013
    Messages:
    11
    Likes Received:
    0
    I had the same problem as the OP after upgrading to 4.0.2. My compass measurements were static -- no matter how I moved the thing they wouldn't change in NAZA and were way out of calibration. I worried that when I did the magnet trick I might have actually broken the thing. I kept at it circulating with a magnet, and also gave the digital compass a hard flick with my fingers a few times in case the magnet had moved anything and gotten stuck. Eventually it snapped out of it and I started getting measurements again and was able to calibrate.
     
  12. kenskid

    Joined:
    Aug 3, 2013
    Messages:
    146
    Likes Received:
    1
    I can tell you right now...that crazy 8 foot circle thing is not good. I had that twice and ignored the sign. Crash both times. Unless the wind is blowing, my Phantom stays in a two foot area and is as stable as a rock.

    I don't have a solution for you but I know it needs to be tuned up!


     
  13. tahoefirefighter

    Joined:
    Dec 14, 2013
    Messages:
    1
    Likes Received:
    0
    I'm having the same problems. I have have tried all the fixes that have been mentioned. My problem is I don't get any LED lights when it is on battery power. So how do I get it to come on so I can calibrate the compass? I have a green light now on my controller as well??? I have a solid green LED on the dji phantom when it is plugged into the computer (that makes me think its not a bad LED). I can fly in Atti mode but no GPS. I have tried upgrading multiple times and even downgrading. Still not working. It was flying perfectly before I started the upgrade. Please HELP! Thanks!
     
  14. RCWatchman

    Joined:
    Dec 10, 2013
    Messages:
    18
    Likes Received:
    0
    Re: 4.2 Woes, I got it fixed, life is good...

    I got it fixed, I got it fixed, and it flies like its on rails. As someone told me, I used the magnet too soon and should have just done the compass dance right after I did the firmware update. I was mistaken and tried to reload the new firmware a second time and could not get it to do that because of the compass error that showed up after the first firmware update attempt. At that time, if I had done the dance I think it would have been OK.

    Well, I used a magnet and did that procedure wrong as well. In using the magnet I was way too concerned with getting the Mod # up, I did not even considering the X, Y and Z #s. I was trying to hit a Mod # of 1500 or so and could only get it to 720. I did not take into consideration that the X, Y and Z where way off I only knew that the Error message went away so I did an advanced calibration, did the dance and it flew, but really unstable. I thought I was doomed.

    I gave one more attempt. I got a magnet that was capable of lifting 10 lbs., hooked the Phantom up to the computer and watched the numbers change. I did not touch the compass but did orbits all around and under it and this time looked for the X, Y, Z settings once I got them back to around -200 or so with a Mod# of 375, I took it for the dance and when I hooked it up it was all right where it should be again with a Mod # value of 1600 or so. I then took it out side and danced again and it dropped to a Mod # of 1520 and holding.

    Pay attention to the post on page 1 of Thor 555, he is spot on with his take on what needs to be done. Thank you, very much.

    One more thing, and this may have played a role in the 8 foot circle flight of its own piloting. I did the calibration of the control sticks on the TX. Do this carefully and get it right.

    I took it out tonight and flew at a local high school. Once off the ground it hovered, rock solid. I took it up almost out of sight and life is good.

    I thank everyone that had a hand in helping me. I will continue to watch this thread if any body has problems with this, I will help where I can. Don’t give up, I thought all was lost. I did many of the wrong things but was able to get it back right and what I learned was invaluable. May all your flights be low cost. Sorry this is so long but it can be fixed, as I said, don’t give up.
     
  15. thetac

    Joined:
    Sep 9, 2013
    Messages:
    102
    Likes Received:
    0
    Location:
    minnesota
    It is tricky to do.....but the important thing to remember is that you don't just use the button in the naza assistant that says "restore defaults settings" you have to actually download the new defaults from DJI home page (yes its a zip file) once you opened the zip file pull the file (its a .naza file) onto your desktop or somewhere where you can find it. Then click the "import parameters" button in the naza assistant find that file; double click on it and it will be uploaded immediately...you'll see the progress bar in the naza assistant. For those of you using a traditional transmitter/receiver like a dx8/ar8000 it will immediately give you a message telling you to switch the receiver type to the correct one (again using the assistant under the basic/rc tab). You will also notice the low values in the compass mod (both my phantoms were at about 500). power down everything including the transmitter. Then power everything back up. You will have to re enable IOC, do a stick calibration, double check you have the right receiver type, then go over and do an advanced calibration. Also if you want to fly using the "manual" fly mode you will have to re enable that on the basic/rc screen down where it says "control mode switch" because the default is for ATTI. After all that...remove it from the computer, cycle the power, do the compass dance and if you are curious plug it back in to the assistant...you'll see that your compass mods are back to more normal. Hope this covers it in a little more detail..especially for all of us traditional receiver users!! It's too bad DJI didn't make a video showing how to do this step by step for both traditional users and stock receivers when they put out 4.02...they talk about restoring defaults....and then confuse things by having the restore default settings button in the assistant which does nothing....they don't tell you how to use the import button, unzip the file, etc. they give you just enough info to frustrate the shat out of most people!
     
  16. RCWatchman

    Joined:
    Dec 10, 2013
    Messages:
    18
    Likes Received:
    0
    To thetac,
    What you said in the post above this one is right on the money, thank you for your view of things. And again I say thanks to all that bothered to get involved with this thread. The first night I flew after 4.2, I thought I had really messed it up but with all the input, it flies again and solid as you would want. One thing I noticed, I am flying with a duel battery setup with 2 stock batteries. With 4.2 my flight time went from 9.5 min. to 14+. Everything else is stock, props too.
    Thanks again to all, and may all your flights be low cost.

    RCW

    PS To tahoefirefighter, the LED problem I don't know, wish I did. You might do a search and see what you come up with, or start a new thread and post all your symptoms. I wish you well...