Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

3 out of 4 Rotors Work

Discussion in 'Phantom 1 Help' started by BBurke, Feb 24, 2013.

  1. BBurke

    Joined:
    Feb 23, 2013
    Messages:
    1
    Likes Received:
    0
    Received new Phantom on Friday afternoon. Unpacked, assembled, had 3 successful short take-offs in back yard and everything worked great. Went out Saturday to use in an open area with GoPro attached and one of the rotors, and corresponding light underneath won't work. It is like it has no power. I get flashing green light. Any ideas?
     
  2. Gizmo3000

    Joined:
    Jan 25, 2013
    Messages:
    1,859
    Likes Received:
    2
    Location:
    Sherman Oaks, CA
    You'll probably want to contact your dealer, as this is something that shouldn't happen. (and is no doubt **** frustrating).
    I've read that some users have had a single light go out, but never a complete lack of power to one rotor/light.

    I don't know if there's warranty/return issues if you crack open your Phantom, and I don't quite recall what things looked like when I opened up mine (damaged shell), but the motor is attached to the ESC/controller thing (located in the arm), and then the controller thing is connected to the power and NAZA.
    so it could be one of a few things. perhaps it's as simple as the ESC controller getting unplugged from the NAZA (which is scary to think could happen), or perhaps the board itself isn't getting any power. or the board failed.
    But that's really only my guess. so it's possible you could repair it yourself, even if you had to get a new controller board.
    .but you really should consult with your dealer first I'd say.
     
  3. sluebeck

    Joined:
    Jan 20, 2014
    Messages:
    4
    Likes Received:
    0
    I'm having the same exact problem. Can you tell me how your problem was resolved?

    Thank you!