Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

3.16 may have compatiblity issues with older Phantoms?

Discussion in 'General Discussion' started by denodan, Sep 6, 2013.

  1. denodan

    Joined:
    Feb 8, 2013
    Messages:
    359
    Likes Received:
    23
    I have been reading problems with 3.16 firmware issues and seems fly away problems may have increased?

    I wonder how many older Phantoms that have updated to firmware 3.16 have had issues? My older Phantom certainly did and took off never to be found again, so got a new Phantom, which contains a slightly different Naza controller, I believe the new ones contain Naza M V2, and who knows other small firmware twinks?

    When I got my new Phantom the update to 3.16 went well, no problems, no issues, but had toilet Bowl, but have found a fix, which I put in the Help forum describing the fix.

    Now the newer Phantoms, you cannot downgrade, so wondering if this is to do with the different firmware? the newer Phantoms may not be compatibly with the older Firmware updates?

    I was wonder 3.16 may not have a bug, but the older firmware maybe the problems and not 100% compatible with 3.16, which will be more likely for the newer Phantoms.

    It can be common as the product gets older, they twink the firmware in many things, and compatibility issues come about.

    This sort of thing has happened with Neato Robot vacuums, mine is a later version, slight twinks in hardware, and firmware and they state the lastest firmware is not for the older versions, so wonder if this is the problem with the Phantom? 3.16 not fully compatible with the older Naza M, or slightly different main boards, etc.

    After all when they start twinking components can cause slight problems?

    Not saying this maybe the case, as even some newer Phantoms I believe have had issues, but seems most maybe the older Phantoms with the newer firmware, which maybe really for the newer Phantoms, with the newer Naza MV2.
     
  2. marcus_canada

    Joined:
    Jul 22, 2013
    Messages:
    304
    Likes Received:
    4
    What is "older"? What's the earliest firmware these things actually came with?

    My Phantom came with 3.12 which I kept on for the longest time, not wishing to rock the boat. I went to 3.16 just the other day, I did have the toilet bowl thing first flight but after I did an advanced cal and another compass dance, it was good..
     
  3. weven

    Joined:
    May 18, 2013
    Messages:
    35
    Likes Received:
    0
    Location:
    Gold Coast Australia
    I was off the opinion from day one 3.16 was for the Naza M V2, which mine does not have.

    I have left it with 3.14 and it is flying just great.

    Steve
     
  4. denodan

    Joined:
    Feb 8, 2013
    Messages:
    359
    Likes Received:
    23
    Think you are correct, and think it is way so many Phantoms are having trouble, both have 2 different Naza controllers.
     
  5. TickTock

    Joined:
    Mar 31, 2013
    Messages:
    171
    Likes Received:
    1
    Mine is pretty old. Not sure what fw it came with but based on my download history, it looks like 2.02 was the first version I installed. At 3.16 now and it is working fine.
     
  6. Siddy

    Joined:
    May 18, 2013
    Messages:
    25
    Likes Received:
    0
    Been running 3.14 but over last few days swap main board upgraded to 3.16 then had to go back to 1 st board so had to do 3.16 on it.
    Just beed to my 1st indoor flight meet and flipped it twice on takeoff, Just let it lift itself slowly within inches it sat on its head.
    did the compass before hand import defaults before.

    So going to mount 2 zenmuse mounts back on and find somewhere soft.
     
  7. Fdnyfish

    Joined:
    Jun 6, 2013
    Messages:
    664
    Likes Received:
    36
    Location:
    Barnesville, PA
  8. denodan

    Joined:
    Feb 8, 2013
    Messages:
    359
    Likes Received:
    23
    The newer Phantoms will not let you downgrade firmware, you can only upgrade, and when you connect to naza assist and there is an update, seems now to progress it is mandatory to upgrade first if there is an update.