Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

2 Questions

Discussion in 'Phantom 2 Discussion' started by RockyMtnOutdoors, Jan 24, 2014.

  1. RockyMtnOutdoors

    Joined:
    Jan 24, 2014
    Messages:
    18
    Likes Received:
    0
    Location:
    Prince George, BC, Canada
    Hi Folks. I just bought a P2 and have 2 questions

    1st question) I live in BC Canada, and my P2 remote (radio) does not "beep' when its turned on indicating what mode it is in. Also the power led is red, not green like the Youtube videos of others radios, and the screw hole on the back of the radio where you switch between CE and FCC mode is plugged I can't adjust it. Is this normal for Canadian P2's

    2nd question) I bought the H3 2D gimbal mount with the P2 and when its powered up, and the drone is sitting on level desk, the gopro sits about 2 degrees from true horizontal, is there adjustment in this mount to fine tune it so my videos wont be a little tilted? thanks folks
     
  2. Buk

    Buk

    Joined:
    Feb 28, 2013
    Messages:
    653
    Likes Received:
    29
    Location:
    Iowa, United States
    Mine doesn't beep when started up either.

    Have you done all of the updates? At least one addresses gimbal issues.

    Sorry, I haven't even looked at the FCC CE adjustment.
     
  3. iResq

    Joined:
    Dec 23, 2013
    Messages:
    545
    Likes Received:
    2
    Location:
    Annapolis, Maryland
    The CE/FCC & corresponding beep are for the Vision.

    Sent from my DROID RAZR using Tapatalk
     
  4. CouesWhitetail

    Joined:
    Jan 7, 2014
    Messages:
    101
    Likes Received:
    2
    Location:
    Globe, AZ
    Mine doesn't beep and the light is red when it's on.
     
  5. RockyMtnOutdoors

    Joined:
    Jan 24, 2014
    Messages:
    18
    Likes Received:
    0
    Location:
    Prince George, BC, Canada
    OK, thanks guys. That helps