Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

2 Motors start but then then the P3P shuts down

Discussion in 'Pro/Adv Discussion' started by Deanopeps, May 23, 2015.

  1. Deanopeps

    Joined:
    Apr 29, 2015
    Messages:
    3
    Likes Received:
    0
    As per the description on startup only the front motors start up do their quick 2 bursts and then the Front 2 motors stop as well.
    It has the latest firmware installed and only arrived yesterday.
    Done calibration etc
    Have I missed something?
    Thanks
     
  2. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,246
    Likes Received:
    449
    Location:
    Virginia
    When you first start up all 4 motors should start at same time and idle. If you are only getting two motors running you have issues. If you have done the IMU calibration as well as the RC and all show well in the assistant and you move the sticks and see that they al respond. I would suspect you have some damaged or defective ESC/ motors or even possibly the Main board or controller. I would see if you can get an exchange. If not its call support at DJI and RMA time is currently at approx 9 weeks turnaround.
     
  3. Deanopeps

    Joined:
    Apr 29, 2015
    Messages:
    3
    Likes Received:
    0
    That was my fear - thanks for the response
     
  4. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    There's only so much you can do without opening it, and since it hasn't even flown that would be unwise.
    Calibrate sticks in the app, Full IMU whether it says it's needed or not is about it really.