Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

1.5.7 P3S Litchi (on iOS 9) with FCC mod

Discussion in 'Standard/4k Discussion' started by abossy, Oct 4, 2016.

  1. abossy

    Joined:
    Sep 18, 2016
    Messages:
    28
    Likes Received:
    3
    So just wanted to share my experience with this config. I'm a new flyer, having upgraded to 1.6.8 out of the box, only managed to get 100m range on the DJI Go app before it returned to home. This is in a huge open park, not ideal but I'm in the city so it's the best I can do.

    So I do all my reading and research and try some new configurations. As others have found using 1.5.7 with the new version of the DJI go app (3.0.0) causes the telemetry and video operation to lag - basically unusable. So I thought I'd try using Litchi as my primary flight management app - together with 1.5.7 and the FCC mod (I'm in a CE country).

    Well just got back from from taking it down to one of the local high schools which have like 3 huge adjacent ovals. Unfortunately as soon as I took off I'm still getting low range before the video cuts out - but get this. So I'm flying and I'm about 350 meters away - video is breaking up. Controller disconnects, loss of signal - but no return to home! The app became unresponsive and I could just make out the flashing green lights in the distance. So I'm trying for about 5 minutes to adjust the orientation but I'm freaking out at the same time and accidentally using the wrong stick going up in altitude! Finally I get the orientation right and fly back to where I'm standing - all of this flying manually. Then while I've got the bird on the ground footsteps and a figure emerge out of the dark. Turns out while I was trying to reorient and bring it back home, I was just over the edge of the oval hovering over this guys house! so he understandably pissed at this point. I apologised and told him what happened and he was OK with it.

    So lesson learnt - I'm reverting back to stock and just gonna leave it until my windsurfer antenna arrives. Was my bad as well flying just on sunset got dark quick and I lost track of time..will just have to wait till the weekend so I can get out of the city! I'll still look at Litchi for waypoints but won't use it as FPV again - will stick with the stock DJI app for that.

    Just glad I got it back in one piece!
     
  2. Waylander

    Joined:
    Jul 14, 2015
    Messages:
    334
    Likes Received:
    82
    Location:
    West Yorkshire, UK
    Hi
    You don't say how you regained control did you switch from F-Mode ( required by Litchi ) into Atti Mode (switch S2 into middle A-mode position), to fly her back to your location. Did you press RTH button..?
    is RTH set up in the Go app, if you had it set up and you did loose signal it should have returned to home by itself.

    Glad you got it back, and used good manners and self control to deal with the irate home owner.
    Waylander
     
  3. stavrossid

    Joined:
    Feb 25, 2016
    Messages:
    122
    Likes Received:
    82
    Location:
    Athens-Greece
    Happened to me too.
    Disconnection at 150m and no return to home.Thank God I flew it straight so I managed to bring it back manually.

    All these happen the last 3-4 days together with the Extreme Lag thread I opened...
     
  4. abossy

    Joined:
    Sep 18, 2016
    Messages:
    28
    Likes Received:
    3
    Ok so what is the cause from your end? Your saying it's the iOS app? I hope not because I have no android devices and would have to spend an extra $35 for the android version grrrr


    Sent from my iPhone using PhantomPilots
     
  5. toegema

    Joined:
    Mar 10, 2016
    Messages:
    206
    Likes Received:
    43
    Did you try to flip the S2 switch on the RC (left switch) multiple times? This should initiate RTH if you still have the control connection even if there is "nothing" on your screen.


    Sent from my iPhone using PhantomPilots
     
  6. Squinly

    Joined:
    Oct 2, 2016
    Messages:
    34
    Likes Received:
    1
    I haven't verified this but someone wrote on another thread that this is from the Litchi website:

    from Litchi website:
    Warning When using a Phantom 3 Standard or Phantom 3 4K (not to be confused with Phantom 3 Pro), be aware that the aircraft will not return to home automatically if signal is lost while Litchi has some or all control of the aircraft, it will hover instead. The following flight modes are affected: VR with Immersive/Joystick Head Tracking active, Follow, Focus and Track. All other aircraft models and flight modes are unaffected by this issue.
     
  7. abossy

    Joined:
    Sep 18, 2016
    Messages:
    28
    Likes Received:
    3
    Yep saw that last night. Only has fpv mode and did in fact return to home twice before that incident so definelty some kinda bug.

    I think the only thing I haven't tried yet is 1.6.8 with Fcc mod might give it a shot after work today.


    Sent from my iPhone using PhantomPilots
     
  8. abossy

    Joined:
    Sep 18, 2016
    Messages:
    28
    Likes Received:
    3
    Did not try that thanks for the heads up! I did know about it but kinda panicked and forgot all the controls. Just comes with lack of experience I guess.


    Sent from my iPhone using PhantomPilots