Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

1.4 or 1.6

Discussion in 'Pro/Adv Discussion' started by SteUk, Jan 30, 2016.

  1. SteUk

    Joined:
    Jul 10, 2015
    Messages:
    96
    Likes Received:
    8
    Hi I'm currently in the dilemma of my p3p being on fw1.5 after Dji decided to update my perfect flying 1.19 after shell crack repair. Do I go 1.4 or 1.6?
    Thanks
    Ste
     
  2. TheLightSpeedz

    Joined:
    Jan 24, 2016
    Messages:
    1,187
    Likes Received:
    366
    1.6 stay away from 1.5


    Sent from my iPhone using PhantomPilots mobile app
     
  3. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    1.4

    No geo
     
  4. SteUk

    Joined:
    Jul 10, 2015
    Messages:
    96
    Likes Received:
    8
    Ok ill try 1.4 if not happy ill go 1.6 thanks
     
  5. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    I am using 1.4, very happy with that.
     
  6. SteUk

    Joined:
    Jul 10, 2015
    Messages:
    96
    Likes Received:
    8
    Did you downgrade to 1.4?
     
  7. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    No, I have the P3 A from new which I always updated asap, however lots of problems with 1.5.

    With all the offers on the newer advanced at present bought one which had 1.32 but upgraded to get the extra feature set.
     
    SteUk likes this.
  8. SteUk

    Joined:
    Jul 10, 2015
    Messages:
    96
    Likes Received:
    8
    Ok gunna try and downgrade mine when battery is charged
     
  9. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    good luck
     
  10. SteUk

    Joined:
    Jul 10, 2015
    Messages:
    96
    Likes Received:
    8
  11. movius

    Joined:
    Jan 11, 2016
    Messages:
    153
    Likes Received:
    45
    Using the latest 1.6 firmware on my p3p without issue (so far)

    Sent from my SM-N9005 using Tapatalk
     
  12. Yeager74

    Joined:
    Jan 20, 2016
    Messages:
    113
    Likes Received:
    33
    Location:
    Hong Kong, China (for now)
    Why not use 1.6?


    Sent from my iPhone using PhantomPilots mobile app
     
  13. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    2,981
    Likes Received:
    1,122
    Location:
    Yorba Linda, CA
    Does anyone have a list of compatible GO App versions for each firmware version?. Does anyone know how to acquire old app versions? IOS and Android?.
     
  14. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    I'm running Android Go app 2.4.3. Works fine with aircraft FW 1.3 & 1.4. If you need it I have it.

     
  15. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    Because there is no benefit to be had from selecting 1.6 over 1.4. 1.6 was an emergency update primarily released to overcome the battery shutdown issue introduced in 1.5. 1.4 & below do not suffer the battery shutdown issue. The "solution" offered is to limit the Phantom's thrust under certain situations, thereby reducing power & performance. At the same time DJI began implementing the GEO feature. If running 1.4 there are no new features or benefits to running 1.6. Further, once you go to 1.6 you are committed & can't go back to 1.4.

     
    Oso likes this.
  16. chupeta82

    Joined:
    Oct 29, 2015
    Messages:
    73
    Likes Received:
    11
    I try my new phantom 3 pro with the new update 1.6 and I am satisfied with the goods and problems fix from 1.4 and new dröne motors so lovely silence
     
    SteUk likes this.
  17. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    What he said....
     
  18. tcope

    Joined:
    Jan 29, 2015
    Messages:
    3,554
    Likes Received:
    1,397
    Location:
    Salt Lake City, UT
    No GEO unless you use the new (and beta) app. 1.6 firmware alone does not have Geo Fencing. It _does_ correct an issue with cold batteries turning off in mid flight.
     
  19. tcope

    Joined:
    Jan 29, 2015
    Messages:
    3,554
    Likes Received:
    1,397
    Location:
    Salt Lake City, UT
    Release notes from 1.6:
    What’s New: 1. In cold environments, propulsion output is automatically adjusted based on battery temperature and cell voltage. Horizontal and vertical speed is also decreased to avoid triggering battery protection.

    Release notes from 1.5:
    a. Fixes is the drifting issues some people were experiencing. Your P3 should be steady as a rock again now
    b. Fixed upgrade issues related to the camera.
    c. Plauback issues resolved.
    d. The Flight Recorder logs are no READ ONLY.
    e. Fixed P3P no live feed issue some users experienced ( even though OSD data was shown ).
    4.There is NO RC firmware included in this release. But iyuor RCfirmware is older than v1.3.20, it is recomended t upgrade this to v1.3.20 before updating the Aircraft to 1.5.00.30.
    5. There is NO battery update included in this firmware version.
    6.
    The DJI GO All will display the Aircraft firmware as 1.4.10+ after the update is completed sucessfully.

    1.5 was not a battery update. So I don't see how it could have created a problem with the batteries that 1.6 needed to correct by updating the batteries. The problem really happens when it's cold outside so this problem only showed up once winter rolled around.

    So I'd _HIGHLY_ recommend people upgrade to 1.6 firmware, especially if you are flying in colder weather.
     
  20. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    no thanks