Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

1.4.10+ FW

Discussion in 'Pro/Adv Discussion' started by Dukesmaster, Jan 30, 2016.

  1. Dukesmaster

    Joined:
    Jan 30, 2016
    Messages:
    7
    Likes Received:
    4
    One of the few post I have read indicates this is 1.5 FW.
    I have only flown once with my new advanced keeping it close by with no issues so far. I want to start venturing further.

    I looked on dji nfz map and there are none where I live. The international airport 15 miles away isn't even on it.
     
  2. Juhead

    Joined:
    Dec 5, 2015
    Messages:
    83
    Likes Received:
    16
    If that's true then it's highly confusing. Why didn't they just call it 1.5?
     
  3. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    7
    Location:
    Glen Burnie, MD - USA
    I don't think that info was correct. 1.4 shows up as 1.4.10 on mine. I never installed 1.5 but it shows up as 1.5.30 if I recall correctly.

     
    #3 Dirty Bird, Jan 30, 2016
    Last edited: Jan 30, 2016
  4. TrynFlyn

    Joined:
    Nov 4, 2015
    Messages:
    139
    Likes Received:
    42
    This has been reported by some owners with all of the recent updates. 1.4.1 showing as 1.3.2+. 1.5.3 showing as 1.4.10+ and 1.6.4 showing as 1.5.3+.

    I would try to verify the actual installed version. It's not recommended to fly with 1.5.3. If it's a new P3A, it may or may not have a log file on the SD card already. If not, I would recommend trying to downgrade FW to 1.3.2 or reinstalling 1.4.1. Then a hidden log file will be created and show all the FW versions that have been installed.