Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

1.2.8+ rc

Discussion in 'Pro/Adv Discussion' started by Jimkar, Feb 7, 2016.

  1. Jimkar

    Joined:
    Jan 12, 2016
    Messages:
    12
    Likes Received:
    0
    Probably missed something somewhere. My P3A came with the following:
    Remote Controller. 1.2.8+
    Firmware 1.1.9+

    Currently using 2.4.3 on Android. The 1.2.8+ seems like an odd load. Should I upgrade controller to 1.3.2 via USB?
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,103
    Likes Received:
    5,627
    Location:
    US
    You can fly with that firmware if you don't want to upgrade. If you do want to upgrade, then you'll need to install 1.3.2 before installing anything newer. If needed, you can find detailed firmware installation instructions here.
     
  3. fordruid

    Joined:
    Nov 14, 2015
    Messages:
    493
    Likes Received:
    114
    Location:
    Wisconsin
  4. Phantomfreak

    Joined:
    Dec 12, 2015
    Messages:
    196
    Likes Received:
    70
    If it flys well and you are in a warm weather climate I would probably not update firmware. Many would love to go back to 1.1.9 firmware.. If you are in a cold climate then I would say it might be worth it to upgrade firmware to 1.6 for the cold climate revisions made to the battery's circuitry.. I am on 1.6 now for this reason, not because I really wanted it. But I can say after over 50 flights with 1.6 I haven't had any issues with it either.
     
  5. Jimkar

    Joined:
    Jan 12, 2016
    Messages:
    12
    Likes Received:
    0
    Thanks, South Texas here so I think I will stay where I'm at.