Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

1.1.5 vs 1.1.9

Discussion in 'Pro/Adv Discussion' started by REBELimgs, Jul 29, 2015.

  1. REBELimgs

    Joined:
    Jul 12, 2015
    Messages:
    341
    Likes Received:
    91
    On the forums, DJI recommended that I should probably stick with 1.1.5 vs upgrading to 1.1.9.

    I just got a new P3P and it came with 1.1.5. I was wondering if there were any issues with that or if I should find a way to upgrade to 1.1.9.

    Edited: I said 1.1.6 when I meant 1.1.9.
     
    #1 REBELimgs, Jul 29, 2015
    Last edited: Jul 29, 2015
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,969
    Likes Received:
    5,582
    Location:
    US
    1.1.9 is the last bug-free firmware that was released. Here's a link to download it if you'd like to upgrade from your current version:

    http://download.dji-innovations.com...Phantom_3_Professional_Firmware_v1.1.9_en.zip

    I've been flying with this version since it was released and have not experienced any issues with it yet. At this point, it's not a good idea to install firmware released beyond this one. Wait for the next release -- and, wait for a few days after that to see what others think about the new version. There is no way to install older firmware versions, so you always need to make sure it's really what you want to do before doing it.

    If needed, here are instructions for installing new firmware:
    http://www.phantompilots.com/threads/how-to-install-phantom-3-firmware.45178
     
    REBELimgs likes this.
  3. REBELimgs

    Joined:
    Jul 12, 2015
    Messages:
    341
    Likes Received:
    91
    I should be fine going from 1.1.5 to 1.1.9, right? Would this one require me to update the Phantom and Tx as well?
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,969
    Likes Received:
    5,582
    Location:
    US
    Yes. Follow the instructions at my link above.
     
    REBELimgs likes this.
  5. REBELimgs

    Joined:
    Jul 12, 2015
    Messages:
    341
    Likes Received:
    91
    Thanks, I've done it before. Just wanted to make sure even the older updates required both to be updated. Thanks again.
     
  6. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,969
    Likes Received:
    5,582
    Location:
    US
    DJI's release notes usually say whether or not it's required. I just follow all of the steps every time to be sure though.
     
    #6 msinger, Jul 29, 2015
    Last edited: Oct 27, 2015
  7. REBELimgs

    Joined:
    Jul 12, 2015
    Messages:
    341
    Likes Received:
    91
    Not having any luck getting this update started.

    I put the firmware on the root and turned the P3 on with the remote off and it doesn't begin. I've tried it with an addition micro SD card and nothing.

    I'm wondering if it's not gonna let me go from 1.1.5 to 1.1.9. Any ideas?
     
  8. REBELimgs

    Joined:
    Jul 12, 2015
    Messages:
    341
    Likes Received:
    91
    Just spoke with DJI and they said it's the app falsely reporting an older firmware. I guess I already have 1.1.9 installed according to the txt file.